aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/statistics.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
downloadguix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar.gz
guix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.zip
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c2bcc776a6..1c1164b432 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2191,7 +2191,7 @@ and fast file reading.")
;; Remove dataset with unclear license.
(lambda _
(delete-file "vega_datasets/_data/la-riots.csv"))))))
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(propagated-inputs (list python-pandas))
(home-page "https://github.com/altair-viz/vega_datasets")
(synopsis "Example datasets used by Vega-related projects")
@@ -2236,6 +2236,7 @@ and Vega-Lite examples.")
python-jsonschema
python-numpy
python-pandas
+ python-setuptools
python-toolz
python-typing-extensions))
(native-inputs (list python-black
@@ -2323,7 +2324,8 @@ correlated samples from Markov Chain Monte Carlo (MCMC).")
(lambda _
;; Cython extensions have to be built before running the tests.
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
- (propagated-inputs (list python-cython python-numpy))
+ (propagated-inputs (list python-cython python-numpy python-setuptools
+ python-wheel))
(native-inputs (list python-nose))
(home-page "http://github.com/daleroberts/hdmedians")
(synopsis "High-dimensional medians")
@@ -2374,7 +2376,9 @@ machine learning, computer vision, and high-dimensional statistics.")
python-scipy
python-typing-extensions
python-xarray
- python-xarray-einstats))
+ python-xarray-einstats
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/arviz-devs/arviz")
(synopsis "Exploratory analysis of Bayesian models")
(description
@@ -2670,7 +2674,9 @@ sampler for Markov chain Monte Carlo (MCMC).")
python-pytest
python-pytest-randomly
python-pytest-xdist
- python-setuptools-scm))
+ python-setuptools-scm
+ python-setuptools
+ python-wheel))
(home-page
(string-append "https://www.statsmodels.org/v" version "/"))
(synopsis "Statistical modeling and econometrics in Python")