aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-16 12:40:21 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-16 12:40:21 +0000
commit8f524034d8e6fb3033ae0ca401d0c4b8eab69f7a (patch)
tree79524b900c52ae3109c950fe0502f638f41ad35d /gnu/packages/statistics.scm
parent3bd3a572fd48170df2e1fa82413cf2c95c719e1b (diff)
downloadguix-8f524034d8e6fb3033ae0ca401d0c4b8eab69f7a.tar.gz
guix-8f524034d8e6fb3033ae0ca401d0c4b8eab69f7a.zip
gnu: python-lifelines: Update to 0.30.0.
* gnu/packages/statistics.scm (python-lifelines): Update to 0.30.0. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ie486d6c023d79eb3356ffa9050d125e3f39ca3a7
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm38
1 files changed, 23 insertions, 15 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3b8102d8e7..2c6eee2c66 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2544,30 +2544,38 @@ new data from those PDFs.")
(define-public python-lifelines
(package
(name "python-lifelines")
- (version "0.28.0")
+ (version "0.30.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "lifelines" version))
(sha256
- (base32 "0pmjb3z1rw1ia64gw87r6y9x1g4kwpw239gqzsa9qh7xadj75kzf"))))
+ (base32 "065yajlfydi7x7b1sjxp9h3rqgwrd3w9ivxiyph7y5nbbwkzdxpp"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- ;; This accuracy test fails because 0.012 is not < 0.01.
- '(list "-k" "not test_weibull_with_delayed_entries")))
- (propagated-inputs (list python-autograd
- python-autograd-gamma
- python-formulaic
- python-matplotlib
- python-numpy
- python-pandas
- python-scipy))
- (native-inputs (list python-dill
- python-flaky
- python-joblib
- python-pytest))
+ ;; NOTE: Tests take 15-25min to complete on 16 threads and much longer
+ ;; in single one, consider to try enabling --numprocesses option.
+ #~(list ;; "--numprocesses" (number->string (parallel-job-count))
+ ;; This accuracy test fails because 0.012 is not < 0.01.
+ "-k" "not test_weibull_with_delayed_entries")))
+ (native-inputs
+ (list python-dill
+ python-flaky
+ python-joblib
+ python-pytest
+ ;; python-pytest-xdist
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-autograd
+ python-autograd-gamma
+ python-formulaic
+ python-matplotlib
+ python-numpy
+ python-pandas
+ python-scipy))
(home-page "https://github.com/CamDavidsonPilon/lifelines")
(synopsis
"Survival analysis including Kaplan Meier, Nelson Aalen and regression")