aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/statistics.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.zip
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1c1164b432..98745c93e1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2469,7 +2469,8 @@ inference (VI) algorithms.")
(("\"error::DeprecationWarning\",") "")))))))
(propagated-inputs (list python-importlib-metadata python-numpoly
python-numpy python-scipy))
- (native-inputs (list python-pytest python-scikit-learn))
+ (native-inputs (list python-pytest python-scikit-learn python-setuptools
+ python-wheel))
(home-page "https://chaospy.readthedocs.io/en/master/")
(synopsis "Numerical tool for performing uncertainty quantification")
(description "Chaospy is a numerical toolbox for performing uncertainty
@@ -2593,7 +2594,8 @@ Meier, Nelson Aalen and regression.")
#:test-flags
'(list "-k" (string-append "not test_correct_results"
" and not test_correct_results_binary"))))
- (native-inputs (list python-pandas python-pytest))
+ (native-inputs (list python-pandas python-pytest python-setuptools
+ python-wheel))
(propagated-inputs (list python-numpy python-scikit-learn))
(home-page "https://github.com/scikit-learn-contrib/MAPIE")
(synopsis "Module for estimating prediction intervals")
@@ -2621,7 +2623,9 @@ conformal prediction methods intervals.")
(native-inputs (list python-coverage
python-pytest
python-pytest-cov
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://emcee.readthedocs.io/en/stable/")
(synopsis "Ensemble sampling toolkit for MCMC")
(description