aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commit12971d26efa3676b42a026d13d584e6bd8aef975 (patch)
tree1eb38e9c4a60aec167c36a0f1c236f57e8c0211d /gnu/packages/ssh.scm
parent43726107316849c258158ceb875d2e20dee35450 (diff)
downloadguix-12971d26efa3676b42a026d13d584e6bd8aef975.tar.gz
guix-12971d26efa3676b42a026d13d584e6bd8aef975.zip
gnu: openssh: Remove input labels.
* gnu/packages/ssh.scm (openssh)[inputs]: Remove input labels. (openssh-sans-x)[inputs]: Use MODIFY-INPUTS.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 826edb6996..fba1fc1734 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -210,15 +210,16 @@ a server that supports the SSH-2 protocol.")
"1s3nqv57r3l7avsdkzwd575dvxra8h19xpqczl0z3cvcgwabw3i0"))))
(build-system gnu-build-system)
(native-inputs (list groff pkg-config))
- (inputs `(("libedit" ,libedit)
- ("openssl" ,openssl)
- ,@(if (target-hurd?)
- '()
- `(("pam" ,linux-pam)
- ("libfido2" ,libfido2))) ;fails to build on GNU/Hurd
- ("mit-krb5" ,mit-krb5)
- ("zlib" ,zlib)
- ("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
+ (inputs
+ (cons* libedit
+ openssl
+ mit-krb5
+ zlib
+ xauth ; for 'ssh -X' and 'ssh -Y'
+ (if (target-hurd?)
+ '()
+ (list linux-pam
+ libfido2)))) ; fails to build on GNU/Hurd
(arguments
`(#:test-target "tests"
;; Otherwise, the test scripts try to use a nonexistent directory and
@@ -324,7 +325,8 @@ Additionally, various channel-specific options can be negotiated.")
(package
(inherit openssh)
(name "openssh-sans-x")
- (inputs (alist-delete "xauth" (package-inputs openssh)))
+ (inputs (modify-inputs (package-inputs openssh)
+ (delete "xauth")))
(synopsis "OpenSSH client and server without X11 support")))
(define-public guile-ssh