aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-28 00:18:46 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (patch)
treed236f5c2bf529ead180f33a1e6819cd70fc35ea7 /gnu/packages/sphinx.scm
parent1190d8b1487ee56218d53637c3c60e3b0c632518 (diff)
downloadguix-ca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc.tar.gz
guix-ca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc.zip
gnu: python-sphinx: Update to 5.3.0.
* gnu/packages/sphinx.scm (python-sphinx): Update to 5.3.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom check phase; add pre-check phase. [propagated-inputs]: Add python-colorama, python-filelock, python-flake8, python-html5lib, python-isort, python-mypy, python-sphinxcontrib-websupport, and python-types-requests. [native-inputs]: Remove python-html5lib; add python-flit-core. Change-Id: I843d70361cdf707ca67616075f4c71f1e59a72f3
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm49
1 files changed, 29 insertions, 20 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index a99b485302..472d67c016 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -68,37 +68,44 @@
(define-public python-sphinx
(package
(name "python-sphinx")
- (version "5.1.1")
+ (version "5.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Sphinx" version))
(sha256
(base32
- "12cdy3m5c09lpf2bbxzbhm5v5y9fk7jgm94qrzggpq86waj28cms"))))
- (build-system python-build-system)
+ "1dclwwz5rsvlw5rzyad1ar7i0zh4csni6jfp0lyc37zzm7h6s0ji"))))
+ (build-system pyproject-build-system)
(arguments
- `(;; Make sure it is safe to use 'imagemagick' instead of
- ;; 'imagemagick/stable' (see the comment for the "imagemagick" input).
- #:disallowed-references (,imagemagick/stable)
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Requires Internet access.
- (delete-file "tests/test_build_linkcheck.py")
- (substitute* "tests/test_build_latex.py"
- (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
- "@pytest.mark.skip()"))
- (setenv "HOME" "/tmp") ;for test_cython
- (invoke "make" "test")))))))
+ (list
+ #:test-flags
+ ;; These require Internet access.
+ '(list "--ignore=tests/test_build_linkcheck.py"
+ "-k"
+ (string-append
+ "not test_latex_images"
+ ;; XXX: Not clear why this fails with a version comparison
+ ;; failure.
+ " and not test_needs_sphinx"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; for test_cython
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list python-babel
+ python-colorama
python-docutils
- python-jinja2
+ python-filelock
+ python-flake8
+ python-html5lib
python-imagesize
python-importlib-metadata
+ python-isort
+ python-jinja2
+ python-mypy
python-packaging
python-pygments
python-requests
@@ -110,6 +117,8 @@
python-sphinxcontrib-jsmath
python-sphinxcontrib-qthelp
python-sphinxcontrib-serializinghtml
+ python-sphinxcontrib-websupport
+ python-types-requests
;; The Sphinx LaTeX library '\RequirePackage' or \\usepackage
;; these:
@@ -146,7 +155,7 @@
;; by the '#:disallowed-references' above.
imagemagick/stable
python-cython
- python-html5lib
+ python-flit-core
python-pytest
(texlive-updmap.cfg
(list texlive-cm-super texlive-tex-gyre))))