aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 14:33:19 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:07 +0000
commit0e7b61b54799cfea043f30d24c4509304582390b (patch)
tree2a655657fdfeb9bcec52e8395968e2ef28308211 /gnu/packages/sphinx.scm
parent3b996e64f4617e188bb2b2e26ff3472940c39eb4 (diff)
downloadguix-0e7b61b54799cfea043f30d24c4509304582390b.tar.gz
guix-0e7b61b54799cfea043f30d24c4509304582390b.zip
gnu: Add python-sphinx-design.
* gnu/packages/sphinx.scm (python-sphinx-design): New variable. Change-Id: If437de567ff815c94997910db0dd509432ad6001
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index bdd91dd0fc..0218ee4ebc 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -396,6 +396,34 @@ documents click applications.")
to code blocks.")
(license license:expat)))
+(define-public python-sphinx-design
+ (package
+ (name "python-sphinx-design")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/executablebooks/sphinx-design")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n3bxibg9p16i3c3l0w8j0aw9pi9dggz1ixllgrmd9d5hdn6kl57"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-flit-core
+ python-pytest
+ python-pytest-cov
+ python-pytest-regressions))
+ (propagated-inputs
+ (list python-sphinx))
+ (home-page "https://sphinx-design.readthedocs.io/en/furo-theme/")
+ (synopsis "Sphinx extension to designing responsive web components")
+ (description
+ "This package provides a sphinx extension for designing beautiful, view
+size responsive web components.")
+ (license license:expat)))
+
(define-public python-sphinxcontrib-devhelp
(package
(name "python-sphinxcontrib-devhelp")