aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-08 15:47:00 -0400
commit533a893cc6b03f100566760d6e0c8e0500ed7082 (patch)
tree0ecbf89895a400c43d16bb1f6539f1a88aeaa4cf /gnu/packages/speech.scm
parent6a2546f92d07df04e5d700924edd027ed1e2ef11 (diff)
parentc762df54786fd6f005f3b5307323f1d2df3cbf0b (diff)
downloadguix-533a893cc6b03f100566760d6e0c8e0500ed7082.tar.gz
guix-533a893cc6b03f100566760d6e0c8e0500ed7082.zip
Merge branch 'master' into staging
Conflicts: .guix-authorizations gnu/ci.scm gnu/packages/base.scm gnu/packages/databases.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/imagemagick.scm gnu/packages/password-utils.scm gnu/packages/python-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm52
1 files changed, 44 insertions, 8 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 66d8fca31b..093f6f957b 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -2,11 +2,12 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,15 +55,16 @@
(define-public flite
(package
(name "flite")
- (version "2.1")
+ (version "2.2")
(source
(origin
- (method url-fetch)
- (uri
- (string-append "http://www.festvox.org/" name "/packed/" name
- "-" version "/" name "-" version "-release.tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/festvox/flite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "119b7l7pjb1l5raqq24p8rmhdqni49vjh2mgdryrfr575rm3yg67"))))
+ (base32 "1n0p81jzndzc1rzgm66kw9ls189ricy5v1ps11y0p2fk1p56kbjf"))))
(build-system gnu-build-system)
(arguments
;; XXX:
@@ -543,7 +545,7 @@ be used by the sighted.")
(sha256
(base32
"1k2xh13miyv48gh06rgsq2vj25xwj7z6vwq9ilsn8i7ig3nrgzg4"))))))
- (home-page "http://www.cstr.ed.ac.uk/projects/festival/")
+ (home-page "https://www.cstr.ed.ac.uk/projects/festival/")
(synopsis "Speech synthesis system")
(description "Festival offers a general framework for building speech
synthesis systems as well as including examples of various modules. As a
@@ -555,6 +557,40 @@ low level architecture and has a Scheme (SIOD) based command interpreter for
control.")
(license (license:non-copyleft "file://COPYING"))))
+(define-public ekho
+ (package
+ (name "ekho")
+ (version "8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/e-guidedog/Ekho/"
+ version "/ekho-" version ".tar.xz"))
+ (sha256
+ (base32 "1v476kpw09ljj8mavasj4hya2w11jwlx7q22rh1lsn9jkkam5i2a"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("espeak-ng" ,espeak-ng)
+ ("libsndfile" ,libsndfile)
+ ("pulseaudio" ,pulseaudio)))
+ (build-system gnu-build-system)
+ (native-search-paths
+ (list (search-path-specification
+ (variable "EKHO_DATA_PATH")
+ (files '("share/ekho-data")))))
+ (home-page "https://eguidedog.net/ekho.php")
+ (synopsis "Chinese text-to-speech software")
+ (description
+ "Ehko is a Text-To-Speech (TTS) software. It supports Cantonese,
+Mandarin, Toisanese, Zhaoan Hakka, Tibetan, Ngangien and Korean (in trial).
+It can also speak English through eSpeak or Festival.")
+ (license (list license:gpl2+
+ ;; libmusicxml
+ license:mpl2.0))))
+
(define-public sphinxbase
(package
(name "sphinxbase")