aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-09-27 18:59:40 +0200
committerAndreas Enge <andreas@enge.fr>2014-09-27 19:36:57 +0200
commitecb26c101e2b879637fb724782fc09be8618a545 (patch)
treea8a647f7d0fa41a3cc7726b15a7477d43f973054 /gnu/packages/scheme.scm
parentdc47939172d4cfe75f4424684223c109fec6e453 (diff)
downloadguix-ecb26c101e2b879637fb724782fc09be8618a545.tar.gz
guix-ecb26c101e2b879637fb724782fc09be8618a545.zip
gnu: mit-scheme: Fix source file name for mips64el.
* gnu/packages/scheme.scm (mit-scheme): Fix source file name for architectures other than x86_64 and i686.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index f66c3136ea..be57399232 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -37,6 +37,14 @@
#:use-module (gnu packages image)
#:use-module (ice-9 match))
+(define (source-directory system version)
+ (string-append "mit-scheme-"
+ (if (or (string-prefix? "x86_64" system)
+ (string-prefix? "i686" system))
+ ""
+ "c-")
+ version))
+
(define-public mit-scheme
(package
(name "mit-scheme")
@@ -51,7 +59,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(and (zero? (system* "tar" "xzvf"
(assoc-ref inputs "source")))
- (chdir ,(string-append name "-" version))
+ (chdir ,(source-directory (%current-system) version))
(begin
;; Delete these dangling symlinks since they break
;; `patch-shebangs'.
@@ -88,11 +96,13 @@
(method url-fetch)
(uri (string-append "mirror://gnu/mit-scheme/stable.pkg/"
version "/mit-scheme-"
- version "-"
(match (%current-system)
- ("x86_64-linux" "x86-64")
- ("i686-linux" "i386")
- (_ "c"))
+ ("x86_64-linux"
+ (string-append version "-x86-64"))
+ ("i686-linux"
+ (string-append version "-i386"))
+ (_
+ (string-append "c-" version)))
".tar.gz"))
(sha256
(match (%current-system)