aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-17 10:33:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:28:56 +0300
commit82649c6cd7ee0a73c51213d19db1d05370df1f7f (patch)
treeb164d01cb2e08511ee3d7ebde350effb6e2554ac /gnu/packages/rust.scm
parent4c3532d7ab81a20e21d23bcf25e06999fcee2571 (diff)
downloadguix-82649c6cd7ee0a73c51213d19db1d05370df1f7f.tar.gz
guix-82649c6cd7ee0a73c51213d19db1d05370df1f7f.zip
gnu: rust: Remove bundled compiled libraries.
* gnu/packages/rust.scm (rust-bootstrap)[source]: Adjust snippet to also remove bundled pre-compiled shared libraries. (rust-1.55): Same.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9af4ae2703..836afa93a9 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017, 2018 Nikolai Merinov <nikolai.merinov@member.fsf.org>
-;;; Copyright © 2017, 2019-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
@@ -162,7 +162,11 @@
(snippet
'(begin
(for-each delete-file-recursively
- '("src/llvm-project"))))
+ '("src/llvm-project"))
+ ;; Remove vendored dynamically linked libraries.
+ ;; find . -not -type d -executable -exec file {} \+ | grep ELF
+ (delete-file "vendor/vte/vim10m_match")
+ (delete-file "vendor/vte/vim10m_table")))
(patches (search-patches "rustc-1.54.0-src.patch"))
(patch-flags '("-p0")))) ;default is -p1
(outputs '("out" "cargo"))
@@ -368,6 +372,10 @@ safety and thread safety guarantees.")
(for-each delete-file-recursively
'("src/llvm-project"
"vendor/tikv-jemalloc-sys/jemalloc"))
+ ;; Remove vendored dynamically linked libraries.
+ ;; find . -not -type d -executable -exec file {} \+ | grep ELF
+ (delete-file "vendor/vte/vim10m_match")
+ (delete-file "vendor/vte/vim10m_table")
;; Add support for riscv64-linux.
(substitute* "vendor/tikv-jemallocator/src/lib.rs"
((" target_arch = \"s390x\"," all)