aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-28 10:28:38 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:01 +0100
commite0a2398559b35b55397dd9789580fe4d958b489b (patch)
tree9a718f04f584b54d4f36c0d568939e8db92dd1ce /gnu/packages/ruby.scm
parent93a311d7609ecfea018efcd5a83d5dd398a66c6c (diff)
downloadguix-e0a2398559b35b55397dd9789580fe4d958b489b.tar.gz
guix-e0a2398559b35b55397dd9789580fe4d958b489b.zip
gnu: ruby-rb-inotify: Update to 0.10.1.
* gnu/packages/ruby.scm (ruby-rb-inotify): Update to 0.10.1. [arguments]: Update style.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 84c378d986..2806cbf850 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7267,26 +7267,27 @@ IANA Time Zone database packaged as Ruby modules for use with @code{TZInfo}.")
(define-public ruby-rb-inotify
(package
(name "ruby-rb-inotify")
- (version "0.9.10")
+ (version "0.10.1")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "rb-inotify" version))
(sha256
(base32
- "0yfsgw5n7pkpyky6a9wkf1g9jafxb0ja7gz0qw0y14fd2jnzfh71"))))
+ "1jm76h8f8hji38z3ggf4bzi8vps6p7sagxn3ab57qc0xyga64005"))))
(build-system ruby-build-system)
(arguments
- '(#:tests? #f ; there are no tests
- #:phases
- (modify-phases %standard-phases
- ;; Building the gemspec with rake is not working here since it is
- ;; generated with Jeweler. It is also unnecessary because the
- ;; existing gemspec does not use any development tools to generate a
- ;; list of files.
- (replace 'build
- (lambda _
- (invoke "gem" "build" "rb-inotify.gemspec"))))))
+ (list
+ #:tests? #f ; there are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Building the gemspec with rake is not working here since it is
+ ;; generated with Jeweler. It is also unnecessary because the
+ ;; existing gemspec does not use any development tools to generate a
+ ;; list of files.
+ (replace 'build
+ (lambda _
+ (invoke "gem" "build" "rb-inotify.gemspec"))))))
(propagated-inputs
(list ruby-ffi))
(native-inputs