aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-02-23 18:22:31 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-03-02 17:33:53 -0500
commitbda0c1392acf0de99dc635fc655b88858919bc04 (patch)
tree03bcf65dd612020a563654ac64bc3683d6598bae /gnu/packages/ruby.scm
parentf3c96d474f36896413b90ed216457652bb1fa983 (diff)
downloadguix-bda0c1392acf0de99dc635fc655b88858919bc04.tar.gz
guix-bda0c1392acf0de99dc635fc655b88858919bc04.zip
gnu: Add ruby-hoe.
* gnu/packages/ruby.scm (ruby-hoe): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7fc799311c..8b9887622a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -30,6 +30,7 @@
#:use-module (gnu packages gdbm)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ruby))
@@ -114,6 +115,34 @@ a focus on simplicity and productivity.")
(("/bin/sh") (which "sh"))))
%standard-phases)))))
+(define-public ruby-hoe
+ (package
+ (name "ruby-hoe")
+ (version "3.13.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seattlerb/hoe.git")
+ (commit "0c11836"))) ; no release tags :(
+ (sha256
+ (base32
+ "0i8dimf8kxcjgqj9x65bbi3l6hc9p9gbfbb1vmrz42764a4jjbz9"))) )
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases (alist-replace
+ 'build
+ (lambda _ (zero? (system* "rake" "gem")))
+ %standard-phases)))
+ (synopsis "Ruby project management helper")
+ (description
+ "Hoe is a rake/rubygems helper for project Rakefiles. It helps manage,
+maintain, and release projects and includes a dynamic plug-in system allowing
+for easy extensibility. Hoe ships with plug-ins for all the usual project
+tasks including rdoc generation, testing, packaging, deployment, and
+announcement.")
+ (home-page "http://www.zenspider.com/projects/hoe.html")
+ (license license:expat)))
+
(define-public ruby-i18n
(package
(name "ruby-i18n")