aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-08 17:21:01 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:22 -0400
commit06a5e22f66ce4364c3c5c3bbb4e1eae92ee820c2 (patch)
tree1746189347a62e4db076e22a07a22e0d015560d2 /gnu/packages/ruby.scm
parenteaa1170031459b14e02268da4050b40d90d75afa (diff)
downloadguix-06a5e22f66ce4364c3c5c3bbb4e1eae92ee820c2.tar.gz
guix-06a5e22f66ce4364c3c5c3bbb4e1eae92ee820c2.zip
gnu: ruby-webrick: Update to 1.8.1.
* gnu/packages/ruby.scm (ruby-webrick): Update to 1.8.1. [source]: Use git. [arguments]: New field.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d050614c04..82cbfbdeb1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13616,14 +13616,26 @@ interface for the Sentry error logger.")
(define-public ruby-webrick
(package
(name "ruby-webrick")
- (version "1.7.0")
- (source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "webrick" version))
- (sha256
- (base32 "1d4cvgmxhfczxiq5fr534lmizkhigd15bsx5719r5ds7k7ivisc7"))))
+ (version "1.8.1")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ruby/webrick")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xb0mk3cghdir65nmj0mblprbf21blli7267b6yyvxclh307yp6s"))))
(build-system ruby-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'extract-gemspec 'delete-problematic-tests
+ (lambda _
+ ;; The httresponse tests fail for
+ ;; unknown reasons (see:
+ ;; https://github.com/ruby/webrick/issues/112).
+ (delete-file "test/webrick/test_httpresponse.rb"))))))
(home-page "https://github.com/ruby/webrick")
(synopsis "HTTP server toolkit")
(description "WEBrick is an HTTP server toolkit that can be configured as an