aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/robotics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/robotics.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
guix-6f9a80b331ae41d142a49fbeb94b90ee587b6155.zip
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/robotics.scm')
-rw-r--r--gnu/packages/robotics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
index fbf10be366..87dcc6f890 100644
--- a/gnu/packages/robotics.scm
+++ b/gnu/packages/robotics.scm
@@ -57,7 +57,7 @@
`(("sdl2" ,sdl2)))
(propagated-inputs
;; 'Viewer.h' includes 'QGLWidget'.
- `(("qtbase" ,qtbase) ;the viewer module needs Qt5 + MESA
+ `(("qtbase" ,qtbase-5) ;the viewer module needs Qt5 + MESA
("mesa" ,mesa)))
(synopsis "Robot simulator")
(description
@@ -107,7 +107,7 @@ hundred times faster than real-time.")
`(("dashel" ,dashel)
("enki" ,enki)
("protobuf" ,protobuf-3.5) ;for logging
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qttools" ,qttools) ;for libQt5Help, needed by "studio"
("qtwebkit" ,qtwebkit)