aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rdf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-27 14:49:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:26 +0100
commit8fe30f2ac7f96e598d5d00287c22c97170621bb3 (patch)
treebffe4e9e43c5be3daa2ac7a09a870754f0653124 /gnu/packages/rdf.scm
parent37e8eeaafbbfbf260cfbfe2ca5aca08bbedeae35 (diff)
downloadguix-8fe30f2ac7f96e598d5d00287c22c97170621bb3.tar.gz
guix-8fe30f2ac7f96e598d5d00287c22c97170621bb3.zip
gnu: python-rdflib-6: Update to 6.3.2.
* gnu/packages/rdf.scm (python-rdflib-6): Update to 6.3.2. [build-system]: Use pyproject-build-system. [arguments]: Use #:test-flags instead of a custom build phase; update list of disabled tests. [native-inputs]: Add python-poetry-core and python-pytest-cov. Change-Id: I0dd4ecebdf3ef04562c3a3efb37614bf5eec16f5
Diffstat (limited to 'gnu/packages/rdf.scm')
-rw-r--r--gnu/packages/rdf.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 3b72b1a3d7..0a04f01cb8 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -364,33 +364,33 @@ powerful language for representing information.")
(define-public python-rdflib-6
(package
(name "python-rdflib")
- (version "6.1.1")
+ (version "6.3.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rdflib" version))
(sha256
(base32
- "0m7pyq771vl4zf9xd3pxjbg7x6ac97b3djfbv9qq9fch56ps1gwd"))))
- (build-system python-build-system)
+ "1q122padnlmwm4slzpc90hz5bf2nj1d0rk3yxancmx04ywgmkbvj"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'adjust-tests
- (lambda _
- (for-each delete-file
- '(;; This test needs a font that is not shipped.
- "test/test_so_69984830.py"
- ;; These tests need internet access.
- "test/jsonld/test_onedotone.py"
- "test/test_sparql_service.py"
- "test/test_graph.py"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "test/")))))))
+ (list
+ #:test-flags
+ ;; This test needs a font that is not shipped.
+ '(list "--ignore=test/test_so_69984830.py"
+ ;; These tests need internet access.
+ "--ignore=rdflib/extras/infixowl.py"
+ "--ignore=test/test_examples.py"
+ "--ignore=test/test_sparql/test_service.py"
+ "--ignore-glob=test/test_extras/test_infixowl/*.py"
+ "--ignore=test/jsonld/test_onedotone.py"
+ ;; These tests use pip install
+ "--ignore=test/test_misc/test_plugins.py"
+ ;; Unknown causes
+ "--ignore=rdflib/__init__.py"
+ "--ignore=test/test_misc/test_parse_file_guess_format.py")))
(native-inputs
- (list python-pytest))
+ (list python-poetry-core python-pytest python-pytest-cov))
(propagated-inputs
(list python-html5lib python-isodate python-pyparsing))
(home-page "https://github.com/RDFLib/rdflib")