aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-04 15:41:20 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-04 15:41:20 +0100
commitff0a8c590d0f377824aadcc06424ee285086ff5f (patch)
treef8603adee6a9c98e6a35a54b1b593edc34d0e979 /gnu/packages/qt.scm
parent773bab64e8e04ad44d9cbe5ecd334f8a73c7f9c0 (diff)
downloadguix-ff0a8c590d0f377824aadcc06424ee285086ff5f.tar.gz
guix-ff0a8c590d0f377824aadcc06424ee285086ff5f.zip
gnu: qt: Explicitly link with the dbus library.
* gnu/packages/qt.scm (qt, qt-4): Add a configure flag to link explicitly with dbus.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 391cfac77e..5fe01e27c6 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -124,6 +124,8 @@ X11 (yet).")
"-prefix" out
"-opensource"
"-confirm-license"
+ ;; explicitly link with dbus instead of dlopening it
+ "-dbus-linked"
;; drop special machine instructions not supported
;; on all instances of the target
,@(if (string-prefix? "x86_64"
@@ -191,6 +193,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"-prefix" out
"-opensource"
"-confirm-license"
+ ;; explicitly link with dbus instead of dlopening it
+ "-dbus-linked"
;; drop special machine instructions not supported
;; on all instances of the target
,@(if (string-prefix? "x86_64"