aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-13 10:39:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:22 -0400
commitdba277e43681985971b43d146c30e82be084eaa3 (patch)
tree7a9b88fbbc6c1c0751e6d9ea94c8e78628f21ad7 /gnu/packages/qt.scm
parentb4cd976d112031434b9640ac467c2077572e5fd3 (diff)
downloadguix-dba277e43681985971b43d146c30e82be084eaa3.tar.gz
guix-dba277e43681985971b43d146c30e82be084eaa3.zip
gnu: Add qtlanguageserver.
* gnu/packages/qt.scm (qtlanguageserver): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6112acd9b5..8a6750d1c5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1966,6 +1966,30 @@ OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
application without necessarily including a full web browser stack by using
native APIs where it makes sense.")))
+(define-public qtlanguageserver
+ (package
+ (name "qtlanguageserver")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "196iicwpqca2ydpca41qs6aqxxq8ycknw6lm2v00h1w3m86frdbk"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'delete-installed-tests
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/tests")))))))
+ (inputs (list qtbase))
+ (home-page (package-home-page qtbase))
+ (synopsis "Implementation of the Language Server Protocol for Qt")
+ (description "This package provides an implementation of the Language
+Server Protocol (LSP) for Qt.")
+ (license (package-license qtbase))))
+
(define-public qtlocation
(package
(inherit qtsvg-5)