aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-16 21:15:24 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-16 21:16:32 +0100
commit3e291958b0c0288f7a7c1b47eb4a81face06e645 (patch)
tree8b8301256b86e0203ed77f41ced1004089ce53bd /gnu/packages/qt.scm
parent4443bb8da3ddaa13ec86b4b0b75e739d4ca09b03 (diff)
downloadguix-3e291958b0c0288f7a7c1b47eb4a81face06e645.tar.gz
guix-3e291958b0c0288f7a7c1b47eb4a81face06e645.zip
gnu: Add PyQt for Qt-4.
* gnu/packages/qt.scm (python-pyqt-4, python2-pyqt-4): New variables.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm52
1 files changed, 51 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index cb7e367c5a..725ac8a2fa 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -18,7 +18,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages qt)
- #:use-module ((guix licenses) #:select (gpl3 lgpl2.1 x11-style))
+ #:use-module ((guix licenses) #:select (gpl2 gpl3 lgpl2.1 x11-style))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build utils)
@@ -398,3 +398,53 @@ contain over 620 classes.")
("qt" ,qt)))
(inputs
`(("python" ,python-2)))))
+
+(define-public python-pyqt-4
+ (package (inherit python-pyqt)
+ (name "python-pyqt")
+ (version "4.11.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/pyqt/PyQt4/"
+ "PyQt-" version "/PyQt-x11-gpl-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "11jnfjw79s0b0qdd9s6kd69w87vf16dhagbhbmwbmrp2vgf80dw5"))))
+ (native-inputs
+ `(("python-sip" ,python-sip)
+ ("qt" ,qt-4)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (sip (string-append out "/share/sip"))
+ (python-version
+ (string-take
+ (string-take-right (assoc-ref inputs "python") 5)
+ 3))
+ (lib (string-append out "/lib/python"
+ python-version
+ "/site-packages")))
+ (zero? (system* "python" "configure.py"
+ "--confirm-license"
+ "--bindir" bin
+ "--destdir" lib
+ "--sipdir" sip))))
+ %standard-phases)))
+ (license (list gpl2 gpl3)))) ; choice of either license
+
+(define-public python2-pyqt-4
+ (package (inherit python-pyqt-4)
+ (name "python2-pyqt")
+ (native-inputs
+ `(("python-sip" ,python2-sip)
+ ("qt" ,qt-4)))
+ (inputs
+ `(("python" ,python-2)))))