aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-16 20:20:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:15 -0400
commit118f7d0b8b6ca78ae3549636cd81e69e0f4a7efb (patch)
treed7d26ca8f1b9e0256519cb91e0d8b3313fcc1a5a /gnu/packages/qt.scm
parente1c48cb6bf237aaf1ffa89e166dfaca00dcca02f (diff)
downloadguix-118f7d0b8b6ca78ae3549636cd81e69e0f4a7efb.tar.gz
guix-118f7d0b8b6ca78ae3549636cd81e69e0f4a7efb.zip
gnu: qtbase: Disable unstable tst_qpauseanimation test.
* gnu/packages/qt.scm (qtbase) [arguments]: Disable tst_qpauseanimation in check phase.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 61a81a12df..913470c9d3 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -812,8 +812,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
;; attempt to complete paths they assume exist, such as
;; "/home", "/etc" or "/root" and fail.
"tst_qcompleter"
- "tst_qfiledialog") "|")
- ")")))))
+ "tst_qfiledialog"
+ ;; This test is susceptible to the 600 ms timeout used:
+ "tst_qpauseanimation") "|") ")")))))
(replace 'patch-mkspecs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((archdata (search-input-directory outputs "lib/qt6"))