aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-18 14:08:20 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-23 10:56:13 +0100
commitef5cbf9bae96555fc0c1983f30bd466476027b20 (patch)
treecf32016d657d1ffaf46217282e9cfcdca1686338 /gnu/packages/python.scm
parentaa5fac334f611438e2be7687784652644540fe8b (diff)
downloadguix-ef5cbf9bae96555fc0c1983f30bd466476027b20.tar.gz
guix-ef5cbf9bae96555fc0c1983f30bd466476027b20.zip
gnu: Add python-h5py and python2-h5py.
* gnu/packages/python.scm (python-h5py, python2-h5py): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2fcdbcc211..7282233bfa 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -324,6 +324,45 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+(define-public python-h5py
+ (package
+ (name "python-h5py")
+ (version "2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/h/h5py/h5py-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0q4f9l8grf6pwp64xbv8bmyxx416s7h4522nnxac056ap3savbps"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-cython" ,python-cython)
+ ("python-numpy" ,python-numpy)
+ ("hdf5" ,hdf5)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments `(#:tests? #f)) ; no test target
+ (home-page "http://www.h5py.org/")
+ (synopsis "Read and write HDF5 files from Python")
+ (description
+ "The h5py package provides both a high- and low-level interface to the
+HDF5 library from Python. The low-level interface is intended to be a
+complete wrapping of the HDF5 API, while the high-level component supports
+access to HDF5 files, datasets and groups using established Python and NumPy
+concepts.")
+ (license bsd-3)))
+
+(define-public python2-h5py
+ (let ((h5py (package-with-python2 python-h5py)))
+ (package (inherit h5py)
+ (inputs
+ `(("python2-numpy" ,python2-numpy)
+ ,@(alist-delete
+ "python-numpy"
+ (package-inputs h5py)))))))
+
(define-public python-lockfile
(package
(name "python-lockfile")