aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-02-25 20:33:39 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-03-07 15:08:36 +0100
commita1920bc9f25210b243ebd20f0a3624d644d08efb (patch)
tree9fc9151ab7a933f9bc29221906b2b333d8bac053 /gnu/packages/python.scm
parentcd77777602af48a32466d8d720a6c70a89721607 (diff)
downloadguix-a1920bc9f25210b243ebd20f0a3624d644d08efb.tar.gz
guix-a1920bc9f25210b243ebd20f0a3624d644d08efb.zip
gnu: Add python-testlib and python2-testlib.
* gnu/packages/python.scm (python-testlib, python2-testlib): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c28d389f88..112aa4c388 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3312,3 +3312,39 @@ interfaces in an easy and portable manner.")
providing a clean and modern domain specific specification language (DSL) in
Python style, together with a fast and comfortable execution environment.")
(license license:expat)))
+
+(define-public python-testlib
+ (package
+ (name "python-testlib")
+ (version "0.6.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/t/testlib/testlib-"
+ version ".zip"))
+ (sha256
+ (base32 "1mz26cxn4x8bbgv0rn0mvj2z05y31rkc8009nvdlb3lam5b4mj3y"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'unpack
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((unzip (string-append (assoc-ref inputs "unzip")
+ "/bin/unzip"))
+ (source (assoc-ref inputs "source")))
+ (and (zero? (system* unzip source))
+ (chdir (string-append "testlib-" ,version)))))
+ %standard-phases)))
+ (synopsis "Python micro test suite harness")
+ (description "A micro unittest suite harness for Python.")
+ (home-page "https://github.com/trentm/testlib")
+ (license expat)))
+
+(define-public python2-testlib
+ (package-with-python2 python-testlib))