aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-02 17:36:28 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-03 10:22:23 +0100
commit92cb152b371a371c9e37c32da0676f50dd3645ab (patch)
treefda64ef49dfa85256714d0129f4e84ae8b92bee7 /gnu/packages/python.scm
parentbbd0ea77ef13965475408c0e6152580cb16fd572 (diff)
downloadguix-92cb152b371a371c9e37c32da0676f50dd3645ab.tar.gz
guix-92cb152b371a371c9e37c32da0676f50dd3645ab.zip
gnu: Add snakemake.
* gnu/packages/python.scm (snakemake): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee2f5d073a..e0c9d1278c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3300,3 +3300,25 @@ interfaces in an easy and portable manner.")
(define-public python2-netifaces
(package-with-python2 python-netifaces))
+
+(define-public snakemake
+ (package
+ (name "snakemake")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/snakemake/snakemake-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0fi4b63sj60hvi7rfydvmz2icl4wj74djw5sn2gl8hxd02qw4b91"))))
+ (build-system python-build-system)
+ (inputs `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://bitbucket.org/johanneskoester/snakemake")
+ (synopsis "Python-based execution environment for make-like workflows")
+ (description
+ "Snakemake aims to reduce the complexity of creating workflows by
+providing a clean and modern domain specific specification language (DSL) in
+Python style, together with a fast and comfortable execution environment.")
+ (license license:expat)))