aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-14 19:37:56 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-14 19:39:20 +0100
commit880ff77c17918b9cf3cb0432e70a8391b9942ec2 (patch)
tree6a628a0b710cef050c6a0adf06ab463ecaab2d6c /gnu/packages/python.scm
parent092e86f54f5be0481fbe7bd42432e34fe6d7b1df (diff)
downloadguix-880ff77c17918b9cf3cb0432e70a8391b9942ec2.tar.gz
guix-880ff77c17918b9cf3cb0432e70a8391b9942ec2.zip
gnu: Add python-cssselect.
* gnu/packages/python.scm (python-cssselect, python2-cssselect): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bd2e497c0d..4bc023a9f6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3144,3 +3144,37 @@ capabilities to the Python interpreter.")
Cascading Style Sheets. Currently it provides a DOM only and no rendering
options.")
(license lgpl3+)))
+
+(define-public python-cssselect
+ (package
+ (name "python-cssselect")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/c/cssselect/cssselect-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "10h623qnp6dp1191jri7lvgmnd4yfkl36k9smqklp1qlf3iafd85"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ ;; tests fail with message
+ ;; AttributeError: 'module' object has no attribute 'tests'
+ `(#:tests? #f))
+ (home-page
+ "https://pythonhosted.org/cssselect/")
+ (synopsis
+ "CSS3 selector parser and translator to XPath 1.0")
+ (description
+ "Cssselect ia a Python module that parses CSS3 Selectors and translates
+them to XPath 1.0 expressions. Such expressions can be used in lxml or
+another XPath engine to find the matching elements in an XML or HTML document.")
+ (license bsd-3)))
+
+(define-public python2-cssselect
+ (package-with-python2 python-cssselect))