aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 12:34:37 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-31 20:00:00 +0200
commit3cff95cbee7525a99347e3a3e9f2a9cebe55086e (patch)
tree520a1e56ae33868b3a9198bdb8868fb8264f4221 /gnu/packages/python.scm
parentde07c0db4a48cdedc28d7f5b2dcd368f1885e8c9 (diff)
downloadguix-3cff95cbee7525a99347e3a3e9f2a9cebe55086e.tar.gz
guix-3cff95cbee7525a99347e3a3e9f2a9cebe55086e.zip
gnu: Add python-decorator.
* gnu/packages/python.scm (python-decorator, python2-decorator): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23afec7950..f7eb478c3c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2837,6 +2837,34 @@ PNG, PostScript, PDF, and SVG file output.")
(define-public python2-cairocffi
(package-with-python2 python-cairocffi))
+(define-public python-decorator
+ (package
+ (name "python-decorator")
+ (version "3.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/d/decorator/decorator-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0i2bnlkh0p9gs76hb28mafandcrig2fmv56w9ai6mshxwqn0083k"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no test target
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://pypi.python.org/pypi/decorator/")
+ (synopsis "Python module to simplify usage of decorators")
+ (description
+ "The aim of the decorator module is to simplify the usage of decorators
+for the average programmer, and to popularize decorators usage giving examples
+of useful decorators, such as memoize, tracing, redirecting_stdout, locked,
+etc. The core of this module is a decorator factory.")
+ (license license:expat)))
+
+(define-public python2-decorator
+ (package-with-python2 python-decorator))
+
(define-public python-ipython
(package
(name "python-ipython")