aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-04 13:17:35 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-05 12:42:36 -0400
commit0234ca06ceccb6d5ad7c13b98e7998b371bc6c08 (patch)
treed711ec9ae249208a359d8cdd6c3a7e77d1683cfe /gnu/packages/python.scm
parentae64112828824895957038842fb705e846e3b69c (diff)
downloadguix-0234ca06ceccb6d5ad7c13b98e7998b371bc6c08.tar.gz
guix-0234ca06ceccb6d5ad7c13b98e7998b371bc6c08.zip
gnu: Add python-singledispatch.
* gnu/packages/python.scm (python-singledispatch, python2-singledispatch): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8c86d5a768..ddd308bce8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3448,3 +3448,32 @@ Python style, together with a fast and comfortable execution environment.")
library for Python programs. It is useful to implement low-level X clients.
It is written entirely in Python.")
(license gpl2+)))
+
+(define-public python-singledispatch
+ (package
+ (name "python-singledispatch")
+ (version "3.4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/singledispatch/"
+ "singledispatch-" version ".tar.gz"))
+ (sha256
+ (base32
+ "171b7ip0hsq5qm83np40h3phlr36ym18w0lay0a8v08kvy3sy1jv"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page
+ "http://docs.python.org/3/library/functools.html#functools.singledispatch")
+ (synopsis "Backport of singledispatch feature from Python 3.4")
+ (description
+ "This library brings functools.singledispatch from Python 3.4 to Python
+2.6-3.3.")
+ (license license:expat)))
+
+(define-public python2-singledispatch
+ (package-with-python2 python-singledispatch))