aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-22 17:45:26 -0500
committerjgart <jgart@dismail.de>2024-07-25 17:26:09 -0500
commitefc26826400762207cde9f23802cfe75a737963c (patch)
treef581a1ec3a706b8b79cba0ab614ac8dbaa1307bd /gnu/packages/python-xyz.scm
parent119d658d7543c84624719a364fa980cc80c2095d (diff)
downloadguix-efc26826400762207cde9f23802cfe75a737963c.tar.gz
guix-efc26826400762207cde9f23802cfe75a737963c.zip
gnu: python-waitress: Update to 3.0.0.
* gnu/packages/python-xyz.scm (python-waitress): Update to 3.0.0. [build-system]: Use pyproject-build-system. [arguments]: Disable failing test. * gnu/packages/patches/python-waitress-fix-tests.patch: Delete no longer needed patch. * gnu/local.mk: Delete patch line. Change-Id: I5397649e30098627de8c24f6afa2b74413d3446a
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fcf01f3d04..d1b3882cd5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19254,16 +19254,19 @@ templates into Python modules.")
(define-public python-waitress
(package
(name "python-waitress")
- (version "1.1.0")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "waitress" version))
- (patches (search-patches "python-waitress-fix-tests.patch"))
(sha256
(base32
- "1a85gyji0kajc3p0s1pwwfm06w4wfxjkvvl4rnrz3h164kbd6g6k"))))
- (build-system python-build-system)
+ "18dq4bibsv6cfhv6a3b16w2xwycxqkkiwbb0vpcwsd21n1ws8p80"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; https://github.com/Pylons/waitress/issues/443
+ (list #:test-flags #~(list "-k" "not test_service_port")))
+ (native-inputs (list python-pytest python-pytest-cov))
(home-page "https://github.com/Pylons/waitress")
(synopsis "Waitress WSGI server")
(description "Waitress is meant to be a production-quality pure-Python WSGI