aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-04 21:55:49 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:19:41 +0000
commitea6c381cac3aa984c778b08c524affbe13458093 (patch)
tree34e11c2a9b4c0228adf6f1c613e996733b84e40b /gnu/packages/python-xyz.scm
parent1affd2b5aa7f5467a44cf757c4fc0c6956d3f3c9 (diff)
downloadguix-ea6c381cac3aa984c778b08c524affbe13458093.tar.gz
guix-ea6c381cac3aa984c778b08c524affbe13458093.zip
gnu: python-botocore: Update to 1.35.54.
* gnu/packages/python-xyz.scm (python-botocore): Update to 1.35.54. [arguments]<tests>: Enable tests. <test-flags>: Disable some failing tests. [native-inputs]: Add python-jsonschema, python-pytest, python-pytest-xdist, python-setuptools, and python-wheel. Change-Id: I7730f85d5ace5b8643f8e9201ea46e6723b1a022
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 22 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de1f77df45..03d96b525c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19365,24 +19365,37 @@ This software is unmaintained, and new projects should use @code{boto3} instead.
;; are compatible.
(package
(name "python-botocore")
- (version "1.24.35")
+ (version "1.35.54")
(source
(origin
(method url-fetch)
(uri (pypi-uri "botocore" version))
(sha256
- (base32
- "0rv8mvhq5s373zdjs2yb45hzvqcqdh2lp2rbb21jjc8ciwnl5d9n"))))
- (build-system python-build-system)
+ (base32 "0xhsi4gfmzh1r96zlaa55p9i3kvh5lj4grp866dr72lwwnfba6qk"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Many tests are failing.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ #~(list "--numprocesses" "auto"
+ ;; It strugles to find 'botocore'.
+ "--ignore" "tests/functional/leak/test_resource_leaks.py"
+ ;; Tests require networking.
+ "--ignore" "tests/integration")))
+ (native-inputs
+ (list python-jsonschema
+ python-pytest
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-dateutil python-jmespath python-urllib3))
+ (list python-dateutil
+ python-jmespath
+ python-urllib3))
(home-page "https://github.com/boto/botocore")
(synopsis "Low-level interface to AWS")
- (description "Botocore is a Python library that provides a low-level
-interface to the Amazon Web Services (AWS) API.")
+ (description
+ "Botocore is a Python library that provides a low-level interface to the
+Amazon Web Services (AWS) API.")
(license license:asl2.0)))
(define-public python-boto3