aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-20 20:33:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 15:55:05 +0000
commitd3b010c38c449ea17bf7beba48de39acec26ae04 (patch)
tree44cd3be933eb0994beb9f52f9b29b70d9289d82c /gnu/packages/python-xyz.scm
parent8d6389b866d91a72569ecf50ddf313c17430d34b (diff)
downloadguix-d3b010c38c449ea17bf7beba48de39acec26ae04.tar.gz
guix-d3b010c38c449ea17bf7beba48de39acec26ae04.zip
gnu: Respect --cores build argument in some python packages.
Reported by Greg Hogan <code@greghogan.com> in #74445. * gnu/packages/astronomy.scm (python-asdf-astropy, python-astropy, python-photutils, python-poppy, python-regions, python-reproject, python-sunpy, python-spectral-cube, python-stdatamodels, python-pysiaf, python-sbpy, python-asdf-coordinates-schemas, python-roman-datamodels, python-webbpsf, python-yt): [arguments]<test-flags>: Adjust "-n" or "--numprocess" to respect "--cores" build argument. * gnu/packages/check.scm (python-crosshair): Likewise. * gnu/packages/databases.scm (python-fastparquet, python-pycurl, awscli, python-s3transfer): Likewise. * gnu/packages/python-xyz.scm (python-glymur, python-zarr, python-dask): Likewise. Change-Id: Ifbc6435e4ad22b0ae822b485bccca41eaa165cc5
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ceb122e08d..3872b511a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2296,7 +2296,7 @@ Python library and command line interface.")
(arguments
(list
#:test-flags
- #~(list "--numprocesses" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; Failing test due to inability of ctypes.util.find_library()
;; to determine library path, which is patched above.
"--ignore=tests/test_config.py")
@@ -28320,7 +28320,7 @@ codecs for use in data storage and communication applications.")
(arguments
(list
#:test-flags
- #~(list "-n" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; This tests are flaky. The pass several times on my laptop
;; but occasionally fail. They fail pretty reliably on the
;; build farm.
@@ -28845,7 +28845,7 @@ decisions with any given backend.")
(list
;; Avoid coverage
#:test-flags
- #~(list "-n" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
"-m" "not gpu and not slow and not network"
;; These all fail with different hashes. Doesn't seem
;; problematic.