aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2024-11-18 22:31:42 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 22:31:42 +0000
commitc9d60ff8233e626b10780b2a1666634f5bcee56f (patch)
tree55815351898cda0854171af61cfd0f5c7aad97bf /gnu/packages/python-xyz.scm
parentea195b286e301647208a9cef25251fbfc6c8a983 (diff)
downloadguix-c9d60ff8233e626b10780b2a1666634f5bcee56f.tar.gz
guix-c9d60ff8233e626b10780b2a1666634f5bcee56f.zip
gnu: Add python-json-e.
* gnu/packages/python-xyz.scm (python-json-e): New variable. Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I9532100f7b75293a81ea28391bfbd8f8ad07a653
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 52c6850878..0156d311e8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -147,6 +147,7 @@
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
;;; Copyright © 2024 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
@@ -31174,6 +31175,42 @@ and directories in the file system. They are stored as name:data pairs
associated with file system objects (files, directories, symlinks, etc).")
(license license:expat)))
+(define-public python-json-e
+ (package
+ (name "python-json-e")
+ (version "4.8.0")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/json-e/json-e")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zsx17jjhvan1ziq5aaqwids3b9kzx3j8czf9qznqqqvb1n133g8"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Git repository provides implementations for JavaScript, Golang,
+ ;; Python and Rust, pick "py".
+ (add-before 'build 'chdir-to-py
+ (lambda _
+ (chdir "py"))))))
+ (native-inputs
+ (list python-freezegun
+ python-pytest
+ python-pyyaml
+ python-setuptools
+ python-wheel))
+ (home-page "https://json-e.js.org")
+ (synopsis "Data-structure parameterizer for embedding context in JSON objects")
+ (description
+ "This package provides a data-structure parameterization system written
+for embedding context in JSON objects.")
+ (license license:mpl2.0)))
+
(define-public python-json-logger
(package
(name "python-json-logger")