aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 22:05:48 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:41 +0000
commitc7d8d7ab49ee0836743b1f72747915fcd1f00bbc (patch)
treea9bc16bbadea83044f7cd34c3c37bf037b048bf2 /gnu/packages/python-xyz.scm
parent8cbd7e9aa4733fc15e5e2e8252f952f7ccd92fd9 (diff)
downloadguix-c7d8d7ab49ee0836743b1f72747915fcd1f00bbc.tar.gz
guix-c7d8d7ab49ee0836743b1f72747915fcd1f00bbc.zip
gnu: python-diff-cover: Update to 9.2.0.
* gnu/packages/python-xyz.scm (python-diff-cover): Update to 9.2.0. Adjust style. [arguments]<test-flags>: Ignore just one test. [native-inputs]: Remove python-flake8 and python-pytest-flake8; add python-pycodestyle, python-pyflakes, and python-pytest-datadir. [description]: Start from a new line, fix fill column. Change-Id: I01de4b79a8f3ccba8ca943907ddc77c9b8ca26e8
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0987cd9d60..f67869a496 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25440,21 +25440,27 @@ which make common patterns shorter and easier.")
(define-public python-diff-cover
(package
(name "python-diff-cover")
- (version "7.5.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "diff_cover" version))
- (sha256
- (base32
- "1z7bxnij2sqsiz9313nwcak7nshakpq4b6c05v13hkqyhd505cx4"))))
+ (version "9.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "diff_cover" version))
+ (sha256
+ (base32 "0dms5f3axwkjpcck4mlglfn0pga5nmskyc7ahyg8yrxvxd9v7845"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- ;; missing fixture 'datadir'.
- '(list "--ignore=tests/test_clover_violations_reporter.py"
- ;; Difference in line breaks
- "-k" "not test_html_with_external_css")))
+ ;; Dropp check of flake8 in tests.
+ #~(list "-k" "not test_file_does_not_exist")))
+ (native-inputs
+ (list python-pycodestyle
+ python-poetry-core
+ python-pyflakes
+ python-pylint
+ python-pytest
+ python-pytest-datadir
+ python-pytest-mock))
(propagated-inputs
(list python-chardet
python-jinja2
@@ -25462,19 +25468,13 @@ which make common patterns shorter and easier.")
python-pygments
python-setuptools ; For pkg_resources.
python-tomli))
- (native-inputs
- (list python-flake8
- python-poetry-core
- python-pylint
- python-pytest
- python-pytest-flake8
- python-pytest-mock))
(home-page "https://github.com/Bachmann1234/diff-cover")
(synopsis "Run coverage and linting reports on diffs")
- (description "Automatically find diff lines that need test coverage. It
-also finds diff lines that have violations (according to tools such as
-pycodestyle, pyflakes, flake8, or pylint). This is used as a code quality
-metric during code reviews.")
+ (description
+ "Automatically find diff lines that need test coverage. It also finds
+diff lines that have violations (according to tools such as pycodestyle,
+pyflakes, flake8, or pylint). This is used as a code quality metric during
+code reviews.")
(license license:asl2.0)))
(define-public python-diff-match-patch