aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-04 22:21:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:19:41 +0000
commitc66639559a33f660cb05c6cccf7e8344aef4fe92 (patch)
tree09d9750dd565bade62509e9f60ddd42d5b032d28 /gnu/packages/python-xyz.scm
parentc83197d3eb2797f364e26f75795f3fb5b4c84caf (diff)
downloadguix-c66639559a33f660cb05c6cccf7e8344aef4fe92.tar.gz
guix-c66639559a33f660cb05c6cccf7e8344aef4fe92.zip
gnu: python-boto3: Update to 1.35.54.
* gnu/packages/python-xyz.scm (python-boto3): Update to 1.35.54. Improve package style. [bulid-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest-xdist, python-setuptools, and python-wheel. Change-Id: I413fcfc599d0d3ccf8587136629648c8a04cd364
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm48
1 files changed, 26 insertions, 22 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03d96b525c..9bb201799d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19401,31 +19401,35 @@ Amazon Web Services (AWS) API.")
(define-public python-boto3
(package
(name "python-boto3")
- (version "1.21.35")
- (home-page "https://github.com/boto/boto3")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1kdyf238rpfldnpzs0rdh3nhjn6hwfym4faskyhzlgzkf1smmbg1"))))
+ (version "1.35.54")
+ (source
+ (origin
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/boto/boto3")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w0k719i8pyzkvd2snv6z91r57k6cxkq1i3phygdpwzk0k6acvj2"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-network-tests
- ;; Deleting integration tests because they are trying to connect to AWS.
- (lambda _
- (delete-file-recursively "tests/integration")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v")))))))
- (build-system python-build-system)
+ (list
+ #:test-flags
+ #~(list "--numprocesses" "auto"
+ ;; Tests require networking.
+ "--ignore" "tests/integration")))
(native-inputs
- (list python-nose python-mock python-pytest))
+ (list python-mock
+ python-nose
+ python-pytest
+ python-pytest-xdist
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-botocore python-jmespath python-s3transfer))
+ (list python-botocore
+ python-jmespath
+ python-s3transfer))
+ (home-page "https://github.com/boto/boto3")
(synopsis "AWS SDK for Python")
(description
"Boto3 is a Python library for writing programs that interact with