aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 16:24:18 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 16:24:18 +0200
commitc4ce54055a75c951f69d1241afc023ddebaf8b4f (patch)
treefd1f713120b7cfb567eb6edd34601df3f85112a1 /gnu/packages/python-xyz.scm
parentcd782ad7e4aee8e2f5bd7fec03f14bdf3175fb80 (diff)
parent4f7f4e82e1f63f49216ee11dcfa67123ef940fcd (diff)
downloadguix-c4ce54055a75c951f69d1241afc023ddebaf8b4f.tar.gz
guix-c4ce54055a75c951f69d1241afc023ddebaf8b4f.zip
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm74
1 files changed, 35 insertions, 39 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b0de9c8dc..eaf88543fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2796,14 +2796,14 @@ audio playback capability for Python 3 on OSX, Windows, and Linux.")
(define-public python-simplejson
(package
(name "python-simplejson")
- (version "3.17.2")
+ (version "3.17.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "simplejson" version))
(sha256
(base32
- "0hc8nqwdlll4a9cr1k9msn5kmb6kmbjirpgvhjh254nr4sgwgv3m"))))
+ "19pqqn01y6qmhhv8q6dh4p1acav49kl923kklnns2qxz5a6h766g"))))
(build-system python-build-system)
(native-inputs
(list python-toml))
@@ -14604,43 +14604,6 @@ both in documentation and via Python’s warnings system, as well as the
that deprecated code is eventually removed.")
(license license:asl2.0)))
-(define-public python-tox
- (package
- (name "python-tox")
- (version "3.20.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "tox" version))
- (sha256
- (base32
- "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
- (build-system python-build-system)
- (arguments
- ;; FIXME: Tests require pytest-timeout, which itself requires
- ;; pytest>=2.8.0 for installation.
- '(#:tests? #f))
- (propagated-inputs
- (list python-filelock
- python-packaging
- python-pluggy
- python-py
- python-six
- python-toml
- python-virtualenv))
- (native-inputs
- (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
- python-pytest ; >= 2.3.5
- python-setuptools-scm))
- (home-page "https://tox.readthedocs.io")
- (synopsis "Virtualenv-based automation of test activities")
- (description "Tox is a generic virtualenv management and test command line
-tool. It can be used to check that a package installs correctly with
-different Python versions and interpreters, or run tests in each type of
-supported environment, or act as a frontend to continuous integration
-servers.")
- (license license:expat)))
-
(define-public python-jmespath
(package
(name "python-jmespath")
@@ -21720,6 +21683,21 @@ Included are implementations of:
@end enumerate\n")
(license license:psfl)))
+(define-public python-typing-extensions-next
+ (package
+ (inherit python-typing-extensions)
+ (name "python-typing-extensions")
+ (version "4.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python/typing")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bbry1rg7q5ppkgzdk4nwl7q1w8bbhajm4q68wb9dm6rf7hg1023"))))))
+
(define-public bpython
(package
(name "bpython")
@@ -29420,6 +29398,24 @@ very small subset the Python stubs contained in the complete @code{typeshed}
collection.")
(license license:asl2.0)))
+(define-public python-types-protobuf
+ (package
+ (name "python-types-protobuf")
+ (version "3.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-protobuf" version))
+ (sha256
+ (base32
+ "000f8n6d4ilihiaf590k73rx3327jh8ima5q5dpxlwz3frj45qrn"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for @code{protobuf}")
+ (description "This package contains typing stubs for @code{protobuf}, a
+very small subset the Python stubs contained in the complete @code{typeshed}
+collection.")
+ (license license:asl2.0)))
+
(define-public python-types-pytz
(package
(name "python-types-pytz")