aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-08-16 19:05:38 -0500
committerjgart <jgart@dismail.de>2024-08-16 19:12:57 -0500
commitbaa21af539477bf16114b48c4b3ac16602e8bb6c (patch)
treecbe1fc97c458eef8ef59a73b40445d67603998ac /gnu/packages/python-xyz.scm
parent0a18e7b9831fd0b7c71466c2c01b573c5d9a268f (diff)
downloadguix-baa21af539477bf16114b48c4b3ac16602e8bb6c.tar.gz
guix-baa21af539477bf16114b48c4b3ac16602e8bb6c.zip
gnu: python-docx: Update to 1.1.2.
* gnu/packages/python-xyz.scm (python-docx): Update to 1.1.2. [source]: Update PyPI source uri. [native-inputs]: Remove python-flake8 and python-mock. Add python-pytest-cov and python-pytest-xdist. [propagated-inputs]: Add python-typing-extensions. Change-Id: Ib43120dcc35a0a24a1456022c4d9ea6fb06f6b20
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7daef3afa2..8f45489fdd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6993,22 +6993,22 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
(define-public python-docx
(package
(name "python-docx")
- (version "0.8.11")
+ (version "1.1.2")
(source (origin
(method url-fetch)
- (uri (pypi-uri "python-docx" version))
+ (uri (pypi-uri "python_docx" version))
(sha256
(base32
- "1i7bxghb7knlyjain101qg1jmmz2b6qj03bi3vfxhvcml0rx418i"))))
+ "1z9ffsvksaaxr90ijzq4k3adzb6p5ipy2j3rrbfjl05rjlpg5w8c"))))
(build-system pyproject-build-system)
(native-inputs
(list behave
- python-flake8
- python-mock
python-pyparsing
- python-pytest))
+ python-pytest
+ python-pytest-cov
+ python-pytest-xdist))
(propagated-inputs
- (list python-lxml))
+ (list python-lxml python-typing-extensions))
(home-page "https://github.com/python-openxml/python-docx/")
(synopsis "Python library to create and modify Microsoft Word documents")
(description "This Python library can be used to create and update