aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 18:27:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:29 +0000
commitb0b7fc0484d84885bde88e70ac4f429139a0188b (patch)
tree11594344524018f8876cbcdaccf74dfc21636bb4 /gnu/packages/python-xyz.scm
parent10af55b09323a05fa9c473715bcabf1bec3ef6ea (diff)
downloadguix-b0b7fc0484d84885bde88e70ac4f429139a0188b.tar.gz
guix-b0b7fc0484d84885bde88e70ac4f429139a0188b.zip
gnu: python-typeguard: Update to 4.4.1.
* gnu/packages/python-xyz.scm (python-typeguard): Update to 4.4.1. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default 'check phase. [propagated-inputs]: Add python-typing-extensions. [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/patches/python-typeguard-python3.10.patch: Delete file. gnu/local.mk: Deregister patch. Change-Id: Ibabc0645b4a6192614d714036fcba1f337924305
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 12 insertions, 19 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3ed37bf6c9..1410f65d29 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27524,30 +27524,23 @@ based on the CPython 2.7 and 3.7 parsers.")
(define-public python-typeguard
(package
(name "python-typeguard")
- (version "2.13.3")
+ (version "4.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "typeguard" version))
(sha256
- (base32 "1i5qzcyw2715h1g1hvj7fxykck2bkxyshpngjr3nfcx1lf6smv80"))
- (patches (search-patches "python-typeguard-python3.10.patch"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-k"
- ;; XXX: These fail when installed as a library:
- ;; https://github.com/agronholm/typeguard/issues/176
- "not usefixtures and not test_cached_module")))))))
- (native-inputs (list python-mypy
- python-pytest
- python-setuptools-scm
- python-typing-extensions))
+ (base32 "06y22d1f5dhpyl71wbhsaibig5hvc2v44pw795yb8lxl02fsh8hd"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-mypy
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-typing-extensions
+ python-wheel))
+ (propagated-inputs
+ (list python-typing-extensions))
(home-page "https://github.com/agronholm/typeguard")
(synopsis "Run-time type checker for Python")
(description