aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-07-26 16:32:16 -0400
committerLeo Famulari <leo@famulari.name>2024-07-26 16:34:22 -0400
commit862a9b5b25966845f71d218ad8c0c5655ffc479a (patch)
tree162a6e7fb669f5803a9c8d22a27d6feb4d11dad3 /gnu/packages/python-xyz.scm
parent72e586fcae78e467d01e2add09c1db26be6bfa93 (diff)
downloadguix-862a9b5b25966845f71d218ad8c0c5655ffc479a.tar.gz
guix-862a9b5b25966845f71d218ad8c0c5655ffc479a.zip
gnu: wfetch: Give the executable the expected name.
Fixes a problem reported by bdju on #guix: https://logs.guix.gnu.org/guix/2024-07-26.log#221323 * gnu/packages/python-xyz.scm (wfetch)[arguments]: Rename the executable in the custom 'install' phase. Change-Id: I0e8dd41195ef716618b9dd5fd196f392a546272a
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d1b3882cd5..f80f4cbc50 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16073,7 +16073,7 @@ structures.")
(define-public wfetch
(let ((commit "e1cfa37814aebc9eb56ce994ebe877b6a6f9a715")
- (revision "1"))
+ (revision "2"))
(package
(name "wfetch")
(version (git-version "0.1-pre" revision commit))
@@ -16101,7 +16101,10 @@ structures.")
(mkdir-p share)
(substitute* "wfetch/wfetch.py"
(("os.sep, 'opt', 'wfetch'") (string-append "'" share "'")))
- (install-file "wfetch/wfetch.py" bin)
+ ; The documentation expects the executable to be named
+ ; 'wfetch', not 'wfetch.py'.
+ (rename-file "wfetch/wfetch.py" "wfetch/wfetch")
+ (install-file "wfetch/wfetch" bin)
(copy-recursively "wfetch/icons" share)))))))
(inputs (list python-pyowm python-fire python-termcolor python-requests))
(synopsis "Command-line tool to display weather info")