aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 10:26:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:40 +0000
commit852368a1068efcbca16b0235076bde954f107852 (patch)
tree35775fca687b2db9c08f4ea4ecd35c5c25de2164 /gnu/packages/python-xyz.scm
parentbaf2bf26350a40ceec9e4b4e6ce8d00d91238715 (diff)
downloadguix-852368a1068efcbca16b0235076bde954f107852.tar.gz
guix-852368a1068efcbca16b0235076bde954f107852.zip
gnu: python-validators: Update to 0.34.0.
* gnu/packages/python-xyz.scm (python-validators): Update to 0.34.0. [build-system]: Swap to pyproject-build-system. [arguments]<tests-flags>: Ignore tests for optional Python module. [native-inputs]: Remove python-flake8 and python-isort; add python-setuptools and python-wheel. [description]: Fix fill column. Change-Id: I100d8f6d71794d17fdfe6bcbaadd43f2f63bd8e0
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 893f5df9ab..2320136308 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26137,30 +26137,33 @@ in pure Python.")
(define-public python-validators
(package
(name "python-validators")
- (version "0.18.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "validators" version))
- (sha256
- (base32
- "19lypf7hm7p203ay3v8zmckc5rv6889zkfdm16nki1972f99mk9p"))))
- (build-system python-build-system)
+ (version "0.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "validators" version))
+ (sha256
+ (base32 "07vq3s77f5yndn7jfx39jbsaq5m8wqc3p52v4i6sgyasnh3y8zv4"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
- (propagated-inputs
- (list python-decorator python-six))
+ (list
+ ;; python-eth-hash is not packed yet.
+ #:test-flags #~(list "--ignore=tests/crypto_addresses/test_eth_address.py")))
(native-inputs
- (list python-flake8 python-isort python-pytest))
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-decorator
+ ;; python-eth-hash ; optional, not packed yet.
+ python-six))
(home-page "https://github.com/kvesteri/validators")
(synopsis "Data validation library")
(description
"This package contains validators for different things such as email
- addresses, IP addresses, URLs, hashes and more. It has been designed to
- be easy to use and not require defining a schema or form just to validate
- some input.")
+addresses, IP addresses, URLs, hashes and more. It has been designed to be
+easy to use and not require defining a schema or form just to validate some
+input.")
(license license:expat)))
(define-public python-validate-email