aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila.lendvai@gmail.com>2023-09-27 17:47:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-03 16:02:02 +0200
commit8036852533b26ce48e82272042ee3ac2a9974ec5 (patch)
tree91ff2f3dc853aa0b4bf7bbab74bfbde94764ed14 /gnu/packages/python-xyz.scm
parent61810fd97352bf46ed4c4fdc6c267518cd6d7095 (diff)
downloadguix-8036852533b26ce48e82272042ee3ac2a9974ec5.tar.gz
guix-8036852533b26ce48e82272042ee3ac2a9974ec5.zip
gnu: Add python-construct-classes.
* gnu/packages/python-xyz.scm (python-construct-classes): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f2828fe54..25027b45fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -143,6 +143,7 @@
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © c4droid <c4droid@foxmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -834,6 +835,31 @@ names for 256 color terminal setups.")
as functions or string constants to form colored terminal output.")
(license license:expat)))
+(define-public python-construct-classes
+ (package
+ (name "python-construct-classes")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/matejcik/construct-classes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fmr8nfg543lyqk4164a52jb6lwpq98radicbkhhdfckq9lib2wp"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-construct))
+ (native-inputs
+ (list python-poetry-core
+ python-pytest))
+ (home-page "https://github.com/matejcik/construct-classes")
+ (synopsis "Parse binary structs into dataclasses")
+ (description "This package provides a parser to parse binary structs
+into dataclasses.")
+ (license license:expat)))
+
(define-public python-yaspin
(package
(name "python-yaspin")