aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 14:58:35 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-14 15:06:30 +0100
commit65d1edf54c7e91d3846a1bac20974128d373335a (patch)
treeb6bf68d5d495126565cd45c041521ce8c31ede7e /gnu/packages/python-xyz.scm
parent51263dc34dba5ea2a8cc6d1eb096a54efcae965b (diff)
downloadguix-65d1edf54c7e91d3846a1bac20974128d373335a.tar.gz
guix-65d1edf54c7e91d3846a1bac20974128d373335a.zip
gnu: autopep8: Update to 2.0.4.
* gnu/packages/python-xyz.scm (autopep8): Update to 2.0.4. [build-system]: Switch to pyproject-build-system. [propagated-inputs]: Replace python-toml by python-tomli. [native-inputs]: Add python-setuptools, python-wheel. [arguments]<#:phases>[prepare-check]: Add phase. Change-Id: I3b92521e5cfe5d527f7836deb653909197b25145
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f0a3986f63..dd955578e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10472,17 +10472,25 @@ from a program in a @dfn{pager} such as @command{less}.")
(define-public python-autopep8
(package
(name "python-autopep8")
- (version "1.5.3")
+ (version "2.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "autopep8" version))
(sha256
(base32
- "1w6vh627vrmgfbvrdcxrc3k4gxcldrb2lpgxv9irkdds851qrzb0"))))
- (build-system python-build-system)
+ "037yhzmc9lssmn6cifa5gvw23f1c0hgsfgn83jfl3cwppm50c4r9"))))
+ (build-system pyproject-build-system)
(propagated-inputs
- (list python-pycodestyle python-toml))
+ (list python-pycodestyle python-tomli))
+ (native-inputs
+ (list python-setuptools python-wheel))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'prepare-check
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
(home-page "https://github.com/hhatto/autopep8")
(synopsis "Format Python code according to the PEP 8 style guide")
(description