aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-04 21:55:39 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:19:41 +0000
commit5297ef6bad968110b2423fc0cdec0b10d9cdcc67 (patch)
treede898df97589e740034a188065a99d5e9294e8c0 /gnu/packages/python-xyz.scm
parent71d8ea41dd67a3d0a0a802c3fca41af4555ce113 (diff)
downloadguix-5297ef6bad968110b2423fc0cdec0b10d9cdcc67.tar.gz
guix-5297ef6bad968110b2423fc0cdec0b10d9cdcc67.zip
gnu: Remove python-boto.
* gnu/packages/python-xyz.scm (python-boto): Delete variable. Change-Id: I4ff3f200734bce027334383d1f56c28134808a9d
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9bb201799d..578ae91cc0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19333,33 +19333,6 @@ enhancements to optimization and data fitting problems.")
browser from Python.")
(license license:bsd-3)))
-(define-public python-boto
- (package
- (name "python-boto")
- (version "2.49.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "boto" version))
- (sha256
- (base32
- "0njy09c4wjx7ipxhwi6vv404nflyiasl78vwwxxpclnql903n3ga"))))
- (build-system python-build-system)
- (arguments
- ;; XXX: This package is unmaintained and has problems with newer versions
- ;; of Python 3 as well as test libraries. 'python-moto' still uses a
- ;; subset of this library, so keep it around for now, but disable tests.
- '(#:tests? #f))
- (propagated-inputs
- (list python-paramiko python-requests))
- (home-page "https://github.com/boto/boto")
- (synopsis "Python interfaces for Amazon Web Services")
- (description
- "This package provides various facilities for interacting with Amazon
-Web Services through Python.
-
-This software is unmaintained, and new projects should use @code{boto3} instead.")
- (license license:expat)))
-
(define-public python-botocore
;; Note: When updating botocore, also make sure that boto3 and awscli
;; are compatible.