aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-13 18:16:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:19:42 +0000
commit4722bec61558db0b63715c38046d6f53c890cd67 (patch)
treed066e162ff5ea16476ebd01b52007953b2595d58 /gnu/packages/python-xyz.scm
parentc1a286d269a85b0b4e7ef44b810f3f10f459b593 (diff)
downloadguix-4722bec61558db0b63715c38046d6f53c890cd67.tar.gz
guix-4722bec61558db0b63715c38046d6f53c890cd67.zip
gnu: python-boto3: Update to 1.35.59.
* gnu/packages/python-xyz.scm (python-boto3): Update to 1.35.59. [native-inputs]: Remove python-nose. Change-Id: Iafc22bafbf6ef185c2d9f4907386bd904ebaecbd
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1739a4c80b..52c6850878 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19363,7 +19363,7 @@ Amazon Web Services (AWS) API.")
(define-public python-boto3
(package
(name "python-boto3")
- (version "1.35.54")
+ (version "1.35.59")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -19372,17 +19372,16 @@ Amazon Web Services (AWS) API.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0w0k719i8pyzkvd2snv6z91r57k6cxkq1i3phygdpwzk0k6acvj2"))))
+ (base32 "10bdzdaw7qg2m5n5ivb2zzsdl7wgjmz05xyxajd4cmk629ick95m"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
#~(list "--numprocesses" "auto"
- ;; Tests require networking.
+ ;; Integration tests are trying to connect to AWS.
"--ignore" "tests/integration")))
(native-inputs
(list python-mock
- python-nose
python-pytest
python-pytest-xdist
python-setuptools