aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 10:06:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:40 +0000
commit2cb76e2fd95ad3b6d4d223bdbefc4add42f1f8c0 (patch)
treec2c742e0828e986565ff5f14b5d362e03129d9a4 /gnu/packages/python-xyz.scm
parent892fb103007104a0c4ce9a81dba8e9c4a984aad3 (diff)
downloadguix-2cb76e2fd95ad3b6d4d223bdbefc4add42f1f8c0.tar.gz
guix-2cb76e2fd95ad3b6d4d223bdbefc4add42f1f8c0.zip
gnu: python-flake8-isort: Update to 6.1.1.
* gnu/packages/python-xyz.scm (python-flake8-isort): Update to 6.1.1. [source]: Adjust URI name as PyPI archive has been changed. [arguments]<test-flags>: Explicitly disable tests as no provided in PyPI archive or git checkout. [native-inputs]: Add python-hatchling. Change-Id: I89442d131e81d4dd4fba0f554c2197676aac38d9
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e94212dc17..893f5df9ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15586,19 +15586,26 @@ TODO notes checker plugin for flake8.")
(define-public python-flake8-isort
(package
(name "python-flake8-isort")
- (version "6.1.0")
+ (version "6.1.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "flake8-isort" version))
+ (uri (pypi-uri "flake8_isort" version))
(sha256
- (base32 "0gk4q504v42hdzpkndczc0kkwnr85jn1h5pvb561jh65p91r6qyl"))))
+ (base32 "1cvh0d18scgq36gqa2vqbifjarln1r3axgq93lzc303ay0y2zy61"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-flake8 python-isort))
- (native-inputs (list python-pytest))
+ (arguments
+ (list
+ #:tests? #f)) ; no tests in PiPY or git checkout
+ (native-inputs
+ (list python-hatchling))
+ (propagated-inputs
+ (list python-flake8
+ python-isort))
(home-page "https://github.com/gforcada/flake8-isort")
(synopsis "Flake8 plugin integrating isort")
- (description "This package provides a flake8 plugin that integrates isort,
+ (description
+ "This package provides a flake8 plugin that integrates isort,
extending flake8 so that it can warn about badly sorted Python import
directives.")
(license license:gpl2+)))