aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 22:25:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:41 +0000
commit143538ea2c9f2a8b611ffb51e848f77e6a403946 (patch)
tree797470db730916e4a75c4d986ccd30ab6baaaee2 /gnu/packages/python-xyz.scm
parent8f7accef59f39a45301a29052c8be9e4ea1e5802 (diff)
downloadguix-143538ea2c9f2a8b611ffb51e848f77e6a403946.tar.gz
guix-143538ea2c9f2a8b611ffb51e848f77e6a403946.zip
gnu: python-marshmallow-jsonapi: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-marshmallow-jsonapi) [build-system]: Swap to pyproject-build-system. [native-inputs]: Remove python-flake8, python-flake8-bugbear, python-mock, and python-tox; add python-setuptools and python-wheel. [description]: Fix fill column. Change-Id: I980c915b1b110931829dec6cc84455919e8f77a5
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 703e50fcdc..5a85f03de5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26262,6 +26262,9 @@ input.")
to and from native Python datatypes.")
(license license:expat)))
+;; XXX: Deprecated upstream: This repository has been archived by the owner on
+;; Jun 6, 2024. It is now read-only.
+;; Consider to remove when nothing is depend on it.
(define-public python-marshmallow-jsonapi
(package
(name "python-marshmallow-jsonapi")
@@ -26272,23 +26275,21 @@ to and from native Python datatypes.")
(uri (pypi-uri "marshmallow-jsonapi" version))
(sha256
(base32 "1d9pxcgmln4gls99vwj1h24qv0lz7fb2jqmqrsiv1pid1snc125x"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-marshmallow))
+ (build-system pyproject-build-system)
(native-inputs
(list python-faker
- python-flake8
- python-flake8-bugbear
python-flask
- python-mock
python-pytest
- python-tox))
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-marshmallow))
(home-page "https://github.com/marshmallow-code/marshmallow-jsonapi")
(synopsis "JSON:API 1.0 formatting with Marshmallow")
(description
"The marshmallow-jsonapi package provides a simple way to produce
- @uref{https://jsonapi.org, JSON:API}-compliant data in any Python Web framework.
- It includes optional utilities to integrate with Flask.")
+@uref{https://jsonapi.org, JSON:API}-compliant data in any Python Web
+framework. It includes optional utilities to integrate with Flask.")
(license license:expat)))
(define-public python-apispec