aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 09:11:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 09:11:05 +0200
commitf196b3b7a53b94fb855cb2e5365468feedda750c (patch)
tree250909dc0aed061b659e9de17bf4c3cf6b65ba22 /gnu/packages/python-web.scm
parent0dc7f773fd08f21a94779484ed947dedc1c15fdd (diff)
downloadguix-f196b3b7a53b94fb855cb2e5365468feedda750c.tar.gz
guix-f196b3b7a53b94fb855cb2e5365468feedda750c.zip
gnu: python-tinycss2: Simplify.
* gnu/packages/python-web.scm (python-tinycss2)[build-system]: Use pyproject-build-system. [arguments]: Remove.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 1 insertions, 25 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0111d5508f..d7ad051007 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5291,31 +5291,7 @@ modules:
(file-name (git-file-name name version))
(sha256
(base32 "0zyc48vbmczpqj7f3f0d7zb3bz29fyj50dg0m6bbwbr5i88kq3sq"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'build
- (lambda _
- ;; A ZIP archive should be generated, but it fails with "ZIP does
- ;; not support timestamps before 1980". Luckily,
- ;; SOURCE_DATE_EPOCH is respected, which we set to some time in
- ;; 1980.
- (setenv "SOURCE_DATE_EPOCH" "315532800")
- (invoke "flit" "build")))
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (wheel)
- (format #true wheel)
- (invoke "python" "-m" "pip" "install"
- wheel (string-append "--prefix=" out)))
- (find-files "dist" "\\.whl$")))))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-webencodings))
(native-inputs