aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 17:37:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:36 +0000
commite106fcfba22b21934503681512eacaa0619c14d9 (patch)
tree6c2fddb601fa3ad5235f44957774a08c9fd2569b /gnu/packages/python-web.scm
parent7938fe7662a1f21c2eaa68cf3b2a31ba1bb3cc44 (diff)
downloadguix-e106fcfba22b21934503681512eacaa0619c14d9.tar.gz
guix-e106fcfba22b21934503681512eacaa0619c14d9.zip
gnu: python-uvloop: Update to 0.21.0.
* gnu/packages/python-web.scm (python-uvloop): Update to 0.21.0. [build-system]: Swap to pyproject-build-system. [arguments]<test-flags>: Disable one test. [native-inputs]: Remove python-cython; add python-cython-3, python-setuptools, and python-wheel. Change-Id: I1124bbfcfc3f333448cb3c08f9d2b08b61a0a46e
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bd39b9e691..ba235d3538 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6344,18 +6344,18 @@ hard or impossible to fix in cssselect.")
(define-public python-uvloop
(package
(name "python-uvloop")
- (version "0.16.0")
+ (version "0.21.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "uvloop" version))
(sha256
- (base32 "0a0jzwrhkszknh14alflrp1db6dyjp7ph730f9yc5lb7gc6c4jzp"))
+ (base32 "1qq46ym3ymzfn4j6fnykfmr1f4qnb7x7p15dlw37hi38v87jpw9v"))
(modules '((guix build utils)))
(snippet
'(begin (delete-file-recursively "vendor")
(delete-file "uvloop/loop.c")))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -6391,14 +6391,19 @@ hard or impossible to fix in cssselect.")
;; It looks like pytest is preventing
;; custom stdout/stderr redirection,
;; even with -s.
- "and not test_process_streams_redirect "))))))))
+ "and not test_process_streams_redirect "
+ ;; FileNotFoundError: [Errno 2] No such file or
+ ;; directory
+ "and not test_process_env_2"))))))))
(native-inputs
(list python-aiohttp
- python-cython
+ python-cython-3
python-psutil
python-pyopenssl
python-pytest
- python-pytest-timeout))
+ python-pytest-timeout
+ python-setuptools
+ python-wheel))
(inputs
(list libuv))
(home-page "https://github.com/MagicStack/uvloop")