aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 22:03:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:04 +0000
commitcf0c0f5538475694cbad18ca7562d000a9db63bc (patch)
tree4b169f3b953339b31c8cf054be00f4004572a46e /gnu/packages/python-web.scm
parent5e4951a53901ccf4500b7392564c9ff72b6bc624 (diff)
downloadguix-cf0c0f5538475694cbad18ca7562d000a9db63bc.tar.gz
guix-cf0c0f5538475694cbad18ca7562d000a9db63bc.zip
gnu: python-scrapy: Fix build.
* gnu/packages/python-web.scm (python-scrapy): Fix build. [phases]{relax-requirements}: Remove redundant phase. [native-inputs]: Add python-wheel. Change-Id: Iecf49315b5e57023e6aa17bbe89f97f5f12111a4
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 095ec911c7..7fd142dca9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8966,11 +8966,6 @@ regular expressions.")
" and not ")))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- ;; "defusedxml>=0.7.1"
- (("0.7.1") "0.6.0"))))
(add-before 'check 'prepare-test-environment
(lambda _
(setenv "HOME" "/tmp"))))))
@@ -9001,7 +8996,8 @@ regular expressions.")
python-pytest-xdist
python-sybil
python-testfixtures
- python-uvloop))
+ python-uvloop
+ python-wheel))
(home-page "https://scrapy.org")
(synopsis "High-level Web crawling and Web scraping framework")
(description "Scrapy is a fast high-level web crawling and web