aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 14:45:14 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:38 +0000
commitba2ed2fb2b2015546e80ecac69ca92525280cd90 (patch)
treece63da782ab97331acc4d2efe208f2ceacc4e9b9 /gnu/packages/python-web.scm
parent69b3eff2a212f4d8a8a4bf6177cb8b74d4f56f11 (diff)
downloadguix-ba2ed2fb2b2015546e80ecac69ca92525280cd90.tar.gz
guix-ba2ed2fb2b2015546e80ecac69ca92525280cd90.zip
gnu: Add python-suds.
* gnu/packages/python-web.scm (python-suds): New variable. Change-Id: I37d0c0757b13ef7b37e1ff19aa00f4460f2c609a
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f1c597463a..8428ce0d32 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9441,6 +9441,27 @@ Interface) framework/toolkit for building async web services in Python.")
and FastAPI.")
(license license:expat)))
+(define-public python-suds
+ (package
+ (name "python-suds")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "suds" version))
+ (sha256
+ (base32 "1byyg7b2ixpr8hc849a6dd0qn5daxqawz6lb3php8lrmsb1n5cc3"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/suds-community/suds")
+ (synopsis "Lightweight SOAP python client for consuming Web Services")
+ (description
+ "Suds is a lightweight SOAP-based web service client for Python.")
+ (license license:lgpl3+)))
+
(define-public python-fastapi
(package
(name "python-fastapi")