aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 11:44:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:27 +0000
commit98c3d491a37fda573929ed4bdc6f618d34bbbf2b (patch)
treee3309537523d46e58b6c25efd63ca4a104bcd11e /gnu/packages/python-web.scm
parent7fd0b73989e5f30b96798f5778cf265aae5bb579 (diff)
downloadguix-98c3d491a37fda573929ed4bdc6f618d34bbbf2b.tar.gz
guix-98c3d491a37fda573929ed4bdc6f618d34bbbf2b.zip
gnu: python-tinycss2: Update to 1.4.0.
* gnu/packages/python-web.scm (python-tinycss2): Update to 1.4.0. [native-inputs]: Remove python-pytest-flake8 and python-pytest-isort. Change-Id: I397b3cd61473fcf90681be1cab784ba7cc16334b
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 069b9ec4ca..85ece68fb2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6276,7 +6276,7 @@ modules:
(define-public python-tinycss2
(package
(name "python-tinycss2")
- (version "1.1.0")
+ (version "1.4.0")
(source
(origin
(method git-fetch)
@@ -6286,13 +6286,14 @@ modules:
(recursive? #true)))
(file-name (git-file-name name version))
(sha256
- (base32 "0zyc48vbmczpqj7f3f0d7zb3bz29fyj50dg0m6bbwbr5i88kq3sq"))))
+ (base32 "11m5vhpdz6zlzq2lqqklkhd0h4jxblpvcrdf9cc4s06nhr9acp0r"))))
(build-system pyproject-build-system)
+ (native-inputs
+ (list python-flit
+ python-pytest
+ python-pytest-cov))
(propagated-inputs
(list python-webencodings))
- (native-inputs
- (list python-flit python-pytest python-pytest-cov
- python-pytest-flake8 python-pytest-isort))
(home-page "https://tinycss2.readthedocs.io/")
(synopsis "Low-level CSS parser for Python")
(description "@code{tinycss2} can parse strings, return Python objects