aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-20 10:59:29 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-20 10:59:29 +0100
commit946e48d1d87ec451e7a6315712f2e86c79961a51 (patch)
tree54d768bac330f75c3aab7f712a97d3bb3991afa4 /gnu/packages/python-web.scm
parent80ee613dec012baf9b87200c9ec5e9537810a6d1 (diff)
downloadguix-946e48d1d87ec451e7a6315712f2e86c79961a51.tar.gz
guix-946e48d1d87ec451e7a6315712f2e86c79961a51.zip
gnu: python-flask-restx: Update to 1.3.0.
* gnu/packages/python-web.scm (python-flask-restx): Update to 1.3.0. [arguments]<#:phases>[check]: Exclude test. Change-Id: Ib01efe9e98e8b9971286a83266011fa0d7b2ca45
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4acb886d0c..abf088b700 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7479,7 +7479,7 @@ requests.")
(define-public python-flask-restx
(package
(name "python-flask-restx")
- (version "0.5.1")
+ (version "1.3.0")
(source
;; We fetch from the Git repo because there are no tests in the PyPI
;; archive.
@@ -7490,7 +7490,7 @@ requests.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "18vrmknyxw6adn62pz3kr9kvazfgjgl4pgimdf8527fyyiwcqy15"))))
+ (base32 "1qmm3i1cdv0bvzsc1gn4ql2dsf1fbx85fk69vcmzpsdxzczmw508"))))
(build-system python-build-system)
(propagated-inputs
(list python-aniso8601 python-flask python-jsonschema python-pytz))
@@ -7509,9 +7509,12 @@ requests.")
(invoke "pytest" "--benchmark-skip" "-k"
;; Those tests need internet access
(string-join
- '("not test_check and not test_valid_value_check \
-and not test_override_app_level"
- "not test_redirect") " and ")))))))
+ '("not test_check"
+ "not test_valid_value_check"
+ "not test_override_app_level"
+ "not test_redirect"
+ "not test_swagger")
+ " and ")))))))
(home-page "https://github.com/python-restx/flask-restx")
(synopsis
"Framework for fast, easy and documented API development with Flask")