aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-28 08:52:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:41 +0000
commit7d46ec3e7af66196ed9f9a3e6ff120b369871915 (patch)
tree8c451a6187572c4d3120f7232e545dd4a0c0a7cf /gnu/packages/python-web.scm
parenta0e5d191c02b33224640ce90de78bb19389866cb (diff)
downloadguix-7d46ec3e7af66196ed9f9a3e6ff120b369871915.tar.gz
guix-7d46ec3e7af66196ed9f9a3e6ff120b369871915.zip
gnu: python-httpx: Update to 0.27.2.
* gnu/packages/python-web.scm (python-httpx): Update to 0.27.2. [native-inputs]: Add python-zstandard. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f836b4ae01..070b2c7e35 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6925,7 +6925,7 @@ Some things HTTP Core does do:
(define-public python-httpx
(package
(name "python-httpx")
- (version "0.24.1")
+ (version "0.27.2")
(source
(origin
;; PyPI tarball does not contain tests.
@@ -6935,7 +6935,7 @@ Some things HTTP Core does do:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "121cnzp5jq638wrvfmxa9q0rwank7q6v5fi1lnih50fd5219yvm8"))))
+ (base32 "1jd5w3nhpvrbj66nk2njvfnk0g1mkxivwa52j2yyhcna1xafsk1p"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -6967,7 +6967,8 @@ Some things HTTP Core does do:
python-trustme
python-uvicorn
python-setuptools
- python-wheel))
+ python-wheel
+ python-zstandard))
(propagated-inputs
(list python-charset-normalizer
python-brotli