aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-09 23:03:49 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:46 +0000
commit799c56265fdbc3c68c262d5b55b201745dc27642 (patch)
tree0baddf3f822824e796094768a99ad07e937f17e0 /gnu/packages/python-web.scm
parent421199790e696a9d23241fd1c5e33ec1cffea20d (diff)
downloadguix-799c56265fdbc3c68c262d5b55b201745dc27642.tar.gz
guix-799c56265fdbc3c68c262d5b55b201745dc27642.zip
gnu: python-pycurl: Update to 7.45.3.
* gnu/packages/python-web.scm (python-pycurl): Update to 7.45.3. [arguments]: Adjust tests. Change-Id: I05120931c979d292c2f888d29c80c93a82a291a0
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 017bcf5087..5448404acd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2038,7 +2038,7 @@ Amazon S3 compatible object storage server.")
(define-public python-pycurl
(package
(name "python-pycurl")
- (version "7.45.2")
+ (version "7.45.3")
(source
(origin
(method git-fetch)
@@ -2048,8 +2048,7 @@ Amazon S3 compatible object storage server.")
"REL_" (string-replace-substring version "." "_")))))
(file-name (git-file-name name version))
(sha256
- (base32
- "1dzdramcgf63m1zg8glhqa3ik9anzjy954mshk7s3z3gsi21n8fp"))))
+ (base32 "0sqxz14p8qvhdb9pvlbrfdldn8s27l6hpv252s77kbbrj2pp294c"))))
(build-system pyproject-build-system)
(arguments
'(#:test-flags
@@ -2064,8 +2063,6 @@ Amazon S3 compatible object storage server.")
;; <tests.multi_callback_test.MultiCallbackTest
;; testMethod=test_multi_socket_action>.timer_result
" and not test_multi_socket_action"
- ;; E pycurl.error: (1, '')
- " and not test_http_version_3"
;; OSError: tests/fake-curl/libcurl/with_gnutls.so: cannot
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_gnutls"
@@ -2076,7 +2073,9 @@ Amazon S3 compatible object storage server.")
;; open shared object file: No such file or directory
" and not test_libcurl_ssl_openssl"
;; Probably due to an expired CA
- " and not test_request_without_certinfo"))
+ " and not test_request_without_certinfo"
+ ;; "A libcurl function was given a bad argument"
+ " and not test_proxy_tlsauth"))
#:phases (modify-phases %standard-phases
(add-before 'build 'configure-tls-backend
(lambda _