aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-09-12 00:30:32 +0200
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-09-12 00:30:32 +0200
commit71735eae4f08a4232dee8e3d7aa16e3f863f9e85 (patch)
treed1bbc7a76a416ecd5a7da0cf1ba06489db795036 /gnu/packages/python-web.scm
parentb46256b162e15420bb034a9e6d65ec46f1c03343 (diff)
downloadguix-71735eae4f08a4232dee8e3d7aa16e3f863f9e85.tar.gz
guix-71735eae4f08a4232dee8e3d7aa16e3f863f9e85.zip
gnu: Add python-waybackpack.
* gnu/packages/python-web.scm (python-waybackpack): New variable. Change-Id: I2ba32918f36a99dc9cb01499b645272b4e5ddb13
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2a7dc8f8b3..e94d0c44b9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9537,3 +9537,27 @@ hardware on Grid'5000 or via OpenStack, to Vagrant, Chameleon, and more.")
(description "Python module to query and edit data stored in a
@url{https://netbox.dev,NetBox} instance.")
(license license:asl2.0)))
+
+(define-public python-waybackpack
+ (package
+ (name "python-waybackpack")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "waybackpack" version))
+ (sha256
+ (base32 "16lcr2hv7gmp199fh3psrnv68j20pfxria8v6gchrpl1jqx9f923"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; would require network (and SSL certificates)
+ (propagated-inputs (list python-requests))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/jsvine/waybackpack")
+ (synopsis
+ "Command-line tool that lets you download the entire Wayback Machine
+archive for a given URL.")
+ (description
+ "This package provides a library and a command-line tool that lets
+you download the entire Wayback Machine archive for a given URL.")
+ (license license:expat)))